このエントリーをはてなブックマークに追加 Twitterでツイート php 5.3.0で非推奨になり、6.0.0で削除される

物覚えが悪いこともあってPHP Manualを見る機会が多いのですが、最近ピンクの警告表示が気になっています。

正規表現関係の仕様が見直されるらしく、POSIX正規表現関数にカテゴライズされている関数がphp 5.3.0で非推奨になり、6.0.0で削除されるとのこと。
ereg
ereg_replace
eregi
eregi_replace
split
spliti
sql_ regcase

ereg_replaceやsplitはそれなりに使っているので、ちょっとゲンナリです。

投稿日:2009年11月11日
  • ※コメントは、スパム対策などのためIPアドレスにて制限しております。
  • ※誹謗や中傷、スパムなど、不適切な内容は公開いたしません。ご了承ください。